Appendix 2
IMAGE PROCESSING AND DIGITIZATION STEPSOption A: Using GIS Image Metadata Files (.IMD)
1. Orthorectifying Imagery
1. Open ArcMap.
2. Using ArcCatalog or the “Add Data” tool, navigate to the folder containing the images.
a. Import the .IMD file from both the multispectral and panchromatic image folders. 
i. If the .IMD files cannot be loaded, follow the alternate directions below (Option B).
3. In the Table of Contents, right click on the multispectral image name and navigate to “Properties” > “Functions”.
a. Right click on the “Geometric Function” and click “Properties”.
b. Navigate to the “Geometric” tab, check the DEM checkbox and add your DEM to the box.
c. Check “Geoid”.
d. Click OK, then OK again.
i. The multispectral image will turn blue. That’s normal.
4. Repeat the above steps for the panchromatic image.
2. Pansharpening of Imagery using ArcMap
1. Open Image Analysis under the Windows tab.
a. Highlight both images.
b. Under the “Processing” section of the Image Analysis window, click the “Pansharpen” icon.
c. A new layer will be produced in the Table of Contents.
d. Close Image Analysis.
2. If the image needs to be reprojected into a different UTM zone, project the new pansharpened raster into desired UTM zone (i.e. 8N) using the “Project Raster” tool found in the ArcToolbox under Data Management Tools > Projections and Transformations > Raster. **Make sure to specify that it will be a .TIF file by manually adding .TIF to the end of the filename**
3. Export and compress the pansharpened image (once it has been reprojected if necessary).
a. Right click on the raster in the Table of Contents and select “Data” > “Export Data”.
i. Click “Use Renderer” and “Force RGB” options. This will force the colour correction.
ii. Specify the cell size as 0.5 by 0.5 if it is not set to that already.
iii. Select the appropriate location where the file will be saved.
iv. Choose an appropriate name for the file, i.e. “FORCED_Image name” (i.e. FORCED_3010_09). 
v. Select “JPEG” for “Compression type”. DO THIS LAST as the compression type will automatically change back to “NONE” if you change some of the other options after you set it. 
vi. [bookmark: _GoBack]Click “Save”.
	

Option B: Using PCI Geomatica
1. Mosaicking and Pansharpening of Imagery
1. Open Geomatica, navigate to Modeler.
2. Close the default module library and use the open file button to navigate to and open the appropriate prebuilt model for mosaicking and pansharpening.
a. “mosAllThenPansharpen.mod”
3. Open the import module for the panchromatic image tiles.
a. Click the “<< Batch” button to expand the batch parameter table.
i. Ensure that the table is empty.
1. Remove any rows that still exist from the last time the model was used.
b. Browse for the raw panchromatic imagery that will be mosaicked then used for the pansharpening of the scene.
c. Select all of the images and open.
i. Batch processing table should now be populated with a row for each image opened.
d. Click through each row in the batch processing table and ensure that the panchromatic raster image band is checked in the “Available Layers” window.
i. Do not check the georeferencing layer.
e. Click “Accept”.
f. Open the import module for the multispectral image tiles.
g. Click the “<< Batch” button to expand the batch parameter table.
i. Ensure that the table is empty.
1. Remove any rows that still exist form the last time the model was used.
h. Browse for the raw multi-spectral imagery that will be mosaicked then used for the pansharpening of the scene.
i. Select all of the images and open.
i. Batch processing table should now be populated with a row for each image opened.
j. Click through each row in the batch processing table and ensure that all the raster bands are checked IN SEQUENTIAL ORDER in the “Available Layers” window.
i. Do not check the georeferencing layer;
ii. Sequential order meaning 1, 2, 3, 4, 5, 6, 7, 8;
iii. There will be either 4 or 8 raster bands for each image and all image tiles will have the same number of bands.
k. Click “Accept”.
4. Open the export module.
a. Determine where you want the pansharpened image to be saved and what it will be called.
i. Ensure it is being saved as a .pix file.
b. Click “Accept”.
5. Click the “Run Batch” button at the top of the modeler window.
6. A pansharpened image of the entire scene will be exported as specified by step 5 when the model finishes.
7. Open each pansharpened image in ArcMap and ensure that it has the correct number of bands, the bands are in the correct order, the pixel size is correct, and the image does not have any noticeable anomalies or errors.
a. Band order for 4 band imagery
1 – Blue
2 – Green
3 – Red
4 – NIR
b. Band order for 8 band imagery
1 – Coastal
2 – Blue
3 – Green
4 – Yellow
5 – Red
6 – Red Edge
7 – NIR1 (Close to red)
8 – NIR2 (Farther from red)
c. Pixel size should be the same as the panchromatic image.
8. Close Modebandler.
2. Orthorectification of Mosaicked Image
A. Creating Ground Control Points
1. Open ArcMap.
a. Import the image to be orthorectified and the control data that will be used to correct the image.
2. Open the georeferencing toolbar.
a. Customize > Toolbars > Georeferencing.
3. Select the image you want to orthorectify in the georeferencing toolbar.
a. If the image does not show up ensure that the coordinate system of the dataframe is the same as the image you want to orthorectify.
4. Click the “View Link Table” button to open the link table.
5. Click the “Add Control Points” button to start creating ground control points (GCPs).
a. First select the point on the image then the point on the control data.
b. After a few GCPs have been placed the residuals will begin to be calculated.
6. Continue adding ground control points until there are an even distribution of points across the image with low residuals.
a. Useful method of quickly creating good GCPs.
i. Place approximately 20 GCPs then sort them by residual (highest to lowest).
ii. One by one uncheck the GCP with the highest residual until the remaining residuals are all below the threshold value or there are less than 10 GCPs checked.
1. If there are less than 10 GCPs recheck all GCPs, create 5-10 more GCPs and recheck.
iii. When there are 10 or more GCPs with acceptable residuals evenly distributed across the image delete all other GCPs.
1. Ensure all GCPs are checked and sorted by residual.
2. One by one delete GCP with the highest residual until only the ones you want to keep remain.
b. Acceptable threshold values for residuals depending on available control data.
i. These values are generalized and specific to the 0.6 m resolution imagery, always try for the lowest possible residuals.
ii. Good distribution of vector data across the image: < 10 m
iii. Poor distribution of vector data across the image:  < 15 m
iv. Good distribution of raster data across the image: < 20 m
v. Poor distribution of raster data across the image: < 30 m
vi. Individual image scenarios may force the residuals to be higher than the threshold values.
7. Save GCPs as a .txt file.
8. In ArcCatlog Navigate to the “customTools.tbx” and open the “utmToGcp” script.
9. Add the image to be orthorectified and the GCP text file into the appropriate inputs then click “OK”.
a. This converts the coordinates of the points placed on the image to pixel row and column values and creates a new text file that can be interpreted by OrthoEngine.
B. Orthorectification of Image
1. Open Geomatica and navigate to OrthoEngine. 
2. Create a new project or open an existing one.
a. If opening an existing one skip to step 5 below.
3. Set the project information and click “OK”.
a. Filename – name and location of where it will be saved
b. Name – Good practice to have it the same as the name of the .prj file
c. Math Modelling Method – select: Optical Satellite Modelling > Rational Function (Compute from GCPs)
4. Set Projection information and click “OK”.
a. Set output projection.
i. UTM > D122 North American 1983 > Zone 7 or 8 > Northern Hemisphere.
b. Output Pixel Spacing – 0.6 m (for pansharpened WV2 imagery), this auto-updates line spacing as well.
c. Select “Set GCP Projection based on Output Projection”.
5. Select the “Data Input” processing step.
6. Click the “Open a new or existing image” button.
7. Click “New Image”.
a. Select the image you created GCPs for in the previous section.
b. Images need to be added one at a time.
8. Select the “GCP Collection” processing step.
9. Click the “Collect GCPs Manually” button.
a. In the image selection window select the image and click “Open”.
b. Populate the bands as 1 (3), 2 (2) and 3 (1) for RGB display and click “Close”.
10. Return to the GCP Collection window.
11. Select “PIX / Text file” as the ground control source.
a. Navigate to the converted GCP text file that corresponds to image. 
b. Ensure the format is IPLXYE.
c. Click “Apply Format”.
d. Ensure the “GCPs extracted from file” text box is populated with all of the GCPs in the text file.
e. Click “OK”.
12. Load the DEM.
13. In the “Accepted Points” table, extract the elevation for each GCP.
a. Select a GCP in the table.
b. Click “Extract Elevation”.
i. Elevation should be updated from 0 to the value of the DEM.
c. Click “Accept”.
d. Repeat for each GCP.
14. Close the GCP Collection window as well as any other Orthoengine windows that are not the main project window.
15. Select the “Ortho Generation” processing step.
16. Click the “Schedule Ortho Production” button.
17. Set the parameters for generating the orthorectified image.
a. Transfer the image from “Available images” to “Images to Process”
b. Format  – TIFF 6.0 (.tif)
c. File – name and location the orthorectified image will be saved
d. Select “DEM file”, click “Browse…” open the DEM used in the steps above
e. Resampling – Nearest 
f. Leave all other options default
g. Click “Generate Orthos”
18. Open orthorectified image in ArcMap.
a. ArcToolbox -> Data Management -> Projections and Transformations -> Raster -> Project Raster
b. Select the orthorectified image as the input raster.
c. Set the output raster dataset as the file name, location, and extension that you want the image to be saved as.
d. Set the output coordinate system to “NAD_1983_UTM_Zone_8N”.
e. Click “OK”.
19. In the properties window, open the Symbology tab.
a. Modify the histogram stretching options until the image is closest to real-life (colour, luminance, shadows etc.).
i. This colour correction will be forced in the next step and unable to be changed later. Since feature identification is based, in part, on visual recognition the better the image is colour corrected the easier feature identification will be.
b. Click “OK”.
20. In the table of contents, right click on the image and select “Save As Layer File…”.
a. Save the file in the appropriate location.
b. This will be handy in case you need to go back and redo anything later.
21. Right click on the image in the table of contents and select “Data” > “Export Data…”.
a. Check the “Use Render” option.
i. This will force the colour correction.
b. Select the appropriate location where the file will be saved.
c. Choose an appropriate name for the file.
d. Select the “JPEG” compression option.
i. DO THIS LAST the compression type will automatically change back to “NONE” if you change some of the other options after you set it.
e. Click “Save”.
3. Creating Stereo 3D Scenes from Satellite Imagery (DAT/EM Summit)
1. Check the size of the .tif file (generated in Step 2.B.21)
a. If it is smaller than 405,000 KB skip to step 3 below.
2. Open the .tif file in Global Mapper.
a. Select “File” > “Export” > “Export Raster/Image Format…”.
b. Ensure “GeoTIFF” is the selected export format and click “OK”.
c. In the “GeoTIFF Options” tab ensure the “File Type” is “8-bit Palette Image” and the TIFF compression is “Default (Packbits)”.
d. In the “Tiling” tab select “Specify Number of Rows and Columns” as the “Tile Layout” and input the number of tiles the image needs to be split into.
i. For simplicity it is best to split the image into 1 row and X columns, or X rows and 1 column.
ii. At most the image will need to be split into 4 tiles.
e. Click “OK”.
f. Specify the base file name and location that the image tiles will be saved and click “Save”.
3. Once the image has been split (if applicable) open Stereo Mate Creator.
a. “Start Menu” > “All Programs” > “Datem Software” > “Utilities” > “Generate Stereomate for Ortho Images”.
4. Drag and drop .tif files into the “image files” text box.
a. If the image was split drop all of the .tif image tiles.
b. If no split was required just drop in the original .tif file.
5. Drag and drop the .las file(s) that covers the image.
a. If the image crosses more than one .las file add both files.
b. The “splitDemFootprint” file in the “dempster.gdb” shows the extent of each .las file.
6. Set the “Stereo shift”.
a. For most images choose “Shift based on ground per pixel of image (1/gpp)”.
b. In mountainous terrain or areas with extreme relief, it is recommended to lower the vertical exaggeration using “Pixel shift per elevation unit”.
i. 0.5 turns the vertical exaggeration down slightly.
ii. 0.2 really mutes the exaggeration which may make interpretation easier.
7. Click “Generate”…The files will be saved in the folder they came from.
8. Once the stereo pairs have been created open Image Creator.
a. “Start Menu” > “All Programs” > “Datem Software” > “Utilities” > “Image Creator
9. Drag and drop both the image and the stereomate into the textbox.
10. Ensure “Type” is set to “PYR”.
a. This generates pyramids for the images for quicker rendering.
11. Click “Process”.
12. Once the pyramids have been created open Summit Professional.
13. Select “File” > “New Project…”
14. Select “LiDAR Stereo Image” and click “OK”
a. Click “Add Model from Images”
b. Select both the original image and the stereomate and click “Open”
i. The stereo pair should appear in the text box.
ii. If the image was split repeat this step until all the stereo pair tiles are listed in the text box.
c. Click “OK”.
15. If the stereo pair does not appear on the screen navigate to the “models” tab in the “Project” window and select the stereo pair.
i. If there are multiple select one at random.
16.  Under the terrain tab on the top of Summit, select “Load DTM File”.
a. Click the “Add Files…” button.
b. Select the .las file(s) used to generate the stereomate in Steps 3-7 and click “Open”.
c. Click “OK”.
d. Once the DTM file is loaded click “OK” on the “DTM Information” window.
17. Click the “Follow Terrain” button (or press ctrl + D).
18. Save the summit project (.smtxml) in an appropriate location.
19. Open the “mapping.smtsln” file.
a. This is a multiple projects file that allows you to easily transfer between projects (satellite images).
20. Right click in the “Projects” tab of the “Projects” window and select “Add Project…”.
a. Navigate to and select the summit project saved in Step 18.
b. Click “Open”.
21. Click “Save”.
22. To switch between summit projects select the project in the “Projects” tab of the “Projects” window then navigate to the “Models” tab in the same window and select one of the stereo pairs.
a. This should open the selected stereo pair in the viewing window.
4. Feature Template Creation for Easy Digitization
1. Open ArcCatalog.
2. Create a file-geodatabase (GDB), e.g. “digitizedFeatures.gdb”.
3. Right-click on your Geodatabase and select “Properties”.
a. Open the domains tab and begin creating domains. These are applicable to any feature class within the GDB, provided that the domain and attribute table field are the same data type (ie. Text and Text). Create both codes and descriptions for each item in the bottom window. The descriptions are what will appear in a dropdown menu in the attribute table fields.
4. Right click on the GDB and create a new Feature Dataset.
a. Create one for each grouping of layers that you plan to create (e.g. Mass Movement, Periglacial, and Hydrological).
5. Right click on the Feature Dataset you created in Step 4.3.
a. Create a new Feature Class, selecting the appropriate data type for the feature (eg. Point, Polygon, or Line). Note that feature class naming convention should match python script naming convention or the script will have to be modified.
6. Right click on the new point feature class and select properties, then open the Fields tab.
a. Begin adding manual entry fields to the feature class attribute table, being sure to select the correct data type (most will be text).
b. When you create a new field that corresponds to one of the domains you created earlier, select that domain in the “Domain” section of the field properties. This will populate a dropdown menu for that field in the attribute table.
c. Repeat until all fields are created and are properly assigned their domains.
7. Save all changes and close ArcCatalog.
8. Open ArcMap and import the created layers (points and lines).
9. Organize your layers in the Table of Contents.
a. Right click on the first layer and navigate to the layer Properties -> Symbology
b. Select “Categories”.
10. Under the Value Field.
a. Select the field you created in the domain that corresponds to all of the features within that class (i.e. The field in the Periglacial class should include all possible options such as ice wedge polygons, pingos, palsas, lithalsas, etc.), and select “Add All Values”.
11. Click OK.
12. Right Click on that same layer.
a. Navigate to Edit Features -> Organize Feature Templates.
13. Select “New Template” and make sure that the appropriate layer is checked.
a. Click “Next” and ensure that all of the possible options for that class appear.
b. Click “Finish”.
14. To test:
a. Right click on that layer and begin editing. The Create Features window should open and display the possible options for digitization.
15. You can alter the symbol in the layer’s symbology tab, which will then update the feature template.
16. Repeat Steps 5 – 15 above for each class.
5. Digitizing Features 
1. Setting up the .mxd File
1. Open ArcMap.
2. Load the layers contained in the “digitizedFeatures.gdb”.
3. Set the symbology for the layers.
a. Open the layer properties and navigate to the Symbology tab.
b. Click the Import button.
c. Navigate to the folder that contains the “digitizedFeatures.gdb” and into the subfolder named “layers” select the .lyr file that corresponds to the layer name.
d.  Select the current value field under “TYPE” dialogue box.
e. Click OK.
f. Repeat for all layers.
4. Load any additional layers, e.g. supplementary data layers.
a. Such as surficial geology, fire history, highway alignment, etc…
5. Set the snapping.
a. From the “Editor” toolbar dropdown, select “Options…” 
b. Check the “Use classic snapping” option.
c. Click “Start Editing” in the “Editor” toolbar.
d. From the “Editor” dropdown, select “Snapping” > “Snapping Window”.
e. Check the “Vertex”, “Edge”, and “End” boxes for all the layers in the “digitizedFeatures.gdb”.
f. Click “Stop Editing” in the “Editor” toolbar.
6. Set the Summit settings for ArcMap.
a. Click on “Customize”.
b. In the “DAT/EM Capture Tools” toolbar select “Options”.
c. Select the “Snap” tab and set the “Snap tolerance” to 5.
d. Select the “Summit Zoom” tab and set the dropdown option to “Summit makes ArcMap zoom”.
7. Save the .mxd file.
a. This will save the digitized feature layer symbology so these steps do not need to be redone every time.
1. Creating Features
1. Open ArcMap.
a. Open your mapping mxd file.
i. If there is no .mxd file see Section 5.A.
b. The digitized feature layers should load and be symbolized correctly when the file opens
i. If this is not the case see Section 5.A.
c. Add any images created in Step 2.B that you are using ArcCatalog.
i. Remove any images you are not using as it will allow ArcMap to run faster.
2. Open Summit Evolution and the Summit multiple projects file created in Section 3.
a. Ensure that the 3D emitter turns bright green, if it’s still dull green unplug it then plug it back in.
3. Load the DTM that corresponds to the image being digitized (SUMMIT).
a. From “Terrain” toolbar click “Load DTM file”.
b. Once DTM is loaded, from “Terrain” toolbar select “Follow terrain”; this forces the cursor to follow the topography.
c. From the DAT/EM Capture Drawing Tools toolbar, select “Snap to objects 3D”.
4. Start an editing session (ARCMAP).
a. Ensure that the layers that will contain the digitized features are the ones that can be edited.
5. Open the “Create Features” and “Attributes” tabs on the editing toolbar and pin them to the side of the document (ARCMAP).
a. It is helpful to split the tabs and have one tab on top and one on the bottom so that both are visible without having to switch between them.
6. Identify and digitize features.
a. Select the feature layer that the line will be drawn in and select “Line” as the feature being drawn (ARCMAP).
i. e.g. Draw a periglacial line around the edge of an ice wedge polygon network.
b. From the CAD toolbar, select “Polyline 3D” or “Close Object” button (SUMMIT).
c. Draw a line in the layer around the perimeter of the feature (SUMMIT).
i. Close RIGHT EYE when digitizing to ensure that the lines follow the edge of the features in the actual image and not the stereo mate image.
ii. If using the “Polyine 3D”, use two lines to delineate the perimeter of the feature to enable snapping the shape closed.
1. Start drawing the line around the perimeter.
2. Stop drawing before the perimeter is fully drawn.
3. Start drawing a second line and snap to where the first line stopped.
4. Stop drawing the second line after the perimeter is closed by snapping to the start of the first line.
iii. If using the “Close Object”, one line is sufficient.
d. Select the point layer that the point will be placed in (ARCMAP).
i. This point corresponds to feature type, e.g. select an ice wedge polygon point for shape delineating ice wedge polygons.
e. Place the point inside the shape that was just digitized (ARCMAP).
f. Add attribute data to point (ARCMAP).
i. In the “Attributes” tab add any additional information required in the fields.
ii. Image information attributes does not need to be added at this stage; this may be done at the end for all points at once.
7. Repeat for all features.
8. Keep editor on.
9. When the entire image is finished being digitized set the image attributes for the image information (ARCMAP).
a. Select all digitized points that fall within the image.
i. The “Select By Location” tool is the easiest way to do this.
b. In the attributes tab select one of the digitized point layers.
i. The layer will show the list of points that are selected.
c. With the layer selected, set the image information attributes.
i. This will set the image attributes for all selected points in the layer.
ii. BE CAREFUL NOT TO ACCIDENTLY SET VALUES FOR ANY OTHER ATTRIBUTES.
d. Repeat for all other point layers.
10. Click “Save Edits” when complete (ARCMAP).
a. Do this often in case ArcMap crashes.
6. Creating Final Data Layers and Analysis Figures
1. Creating / Updating the Data Used to Create the Final Data Layers
1. Open ArcMap.
2. For each image used in the mapping process import the corresponding footprint.shp.
a. There will be a footprint for the panchromatic and the multi-spectral image; both will be the same so just choose one for each image used.
3. Merge all of the footprint shapefiles using the “Merge” geoprocessing tool in ArcMap.
4. Run the “setImageFpAtts” tool in the “customTools” toolbox using the file created by the previous step as the input.
a. This will break down the information in the attribute table into multiple fields that are easier to interpret.
5. Run the “footprintForMultiRasters” tool in the “customTools” toolbox using all of the projected orthorectified images used in the mapping process as inputs.
a. Use the image files before they have been compressed and RGB values forced (Orthorectification of Image, Step 2.B.18).
i. This ensures no holes in the footprints because of false NoData values.
6. Compare the output files from Steps 6.A.4 and 6.A.5.
a. They should be very similar but not exactly the same because of the orthorectification.
7. Run a spatial join with the layers created in Steps 6.A.4 and 6.A.5.
a. Target features: orthorectified footprints (Step 6.A.5);
b. Join features: Image footprint points with image information in attribute table (Step 6.A.4);
c. Join operation: One to many;
d. Keep all target features: Checked;
e. Match option: Have their center in.
1. Running the Script to Generate the Final Data Layers
1. Open “MASTER_featureAttributes.py” in a python integrated development environment (IDE).
2. Paste the path of the digitized features and attribute join data geodatabases in the appropriate locations.
a. Make sure you leave the “r” before the path string.
3. Run the script.
a. Depending on the IDE there is either a button or an option on a dropdown in the main toolbar.
b. Note: layer names created in Section 4.4 must be in the same as in script for script to run. 
4. Once the script finishes there will be final polygon layers in the digitized features geodatabase with complete attribute tables as well as .csv files of the attribute tables in the folder containing the digitized features geodatabase.
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